Adaptive.js 2.0 Dust Helpers

Lucio Jul 13, 2015 03:36PM PDT

Hello,

I'm just starting to play around with Adaptive.js 2.0. I would like to import DustJS default helpers (https://github.com/linkedin/dustjs-helpers), the project structure is a bit confusing: where should I require them?
Thank you,

Best,

L.

Up 0 rated Down
Stewart Yu Jul 14, 2015 02:25PM PDT Mobify Agent

You can require them in `app/adaptation.js` and they will be built into the adaptation. For example:

require([
‘global/router’,
‘adaptivejs/adaptive’,
‘adaptivejs/view’,
‘adaptivejs/utils’,
‘adaptivejs/defaults’,
‘dustHelpers’
],
function(router, Adaptive, View, Utils, Defaults, DustHelpers) {
….

Hope this helps!

Post Your Public Answer

Your name (required)
Your email address (required)
Answer (required)
support@mobify.me
https://cdn.desk.com/
mobify
Loading
seconds ago
a minute ago
minutes ago
an hour ago
hours ago
a day ago
days ago
about
Invalid characters found
/customer/en/portal/articles/autocomplete