How to use mobify for localhost

Suman Jan 09, 2014 01:11AM PST

How we can test mobify for my localhost site.

Up -3 rated Down
Jennifer Jan 09, 2014 10:39AM PST Mobify Agent

Hi Suman,

Thanks for your question. In order to use localhost you’ll need to set your project URL to localhost, if the local site is at a specific path (ex. localhost/homePage) you should add the path as well to the project URL.

In addition to that, you’ll need to make sure that your local site has the Mobify tag on it, since tag injector will not work properly when using localhost. We have a tag installation guide that you may find useful.

Hope this helps,
Jennifer

Up 4 rated Down
Jennifer Jan 09, 2014 01:51PM PST Mobify Agent

Hi Suman,

I did some testing with using localhost in Mobify Studio, and unfortunately tag injector will always be used when you’re using localhost.

We’ve added an item to our backlog to update the behaviour of tag injector. Once that fix gets pushed out you should be able to use localhost, but in the meantime it’s not possible.

Sorry for the confusion,
Jennifer

Up -1 rated Down
Suman Jan 09, 2014 09:58PM PST
Hi Jennifer,

Thanks for your quick reply.
I have done some workaround. But while previewing site using mobify preview in command prompt, then it says
" Running preview at address 0.0.0.0 and port 8080 "
What does it mean and how i could see the preview of my mobify site.

Thanks,
Suman
Up 1 rated Down
Jennifer Jan 10, 2014 09:29AM PST Mobify Agent

Hi Suman,

The “Preview your mobile adaptation” section in our Using Mobify Client document has the information you need. If you look under “Using Mobify Preview” you can follow those instructions and use “http://localhost:8080/” as your bundle location.

Cheers,
Jennifer

Up 3 rated Down
Suman Jan 13, 2014 01:15AM PST
HI Jennifer,

Thanks for your quick replies.

Regards,
Suman
Up -2 rated Down
Jennifer Jan 16, 2014 10:00AM PST Mobify Agent

Hi Suman,

I just wanted to follow up with you, we’ve just pushed out a fix to the Mobify Studio Editor. From your project settings page you can now change your tag injector settings to “Auto”, “Enable” or “Disable”.

This new setting should solve the issue we were running into with trying to use localhost in the Editor. If you set the tag injector setting to “Disable” you should be able to use localhost as your project URL.

Cheers,
Jennifer

Post Your Public Answer

Your name (required)
Your email address (required)
Answer (required)
support@mobify.me
https://cdn.desk.com/
mobify
Loading
seconds ago
a minute ago
minutes ago
an hour ago
hours ago
a day ago
days ago
about
Invalid characters found
/customer/en/portal/articles/autocomplete